Graphics and settings 2021

  Fin: Grafiikan piirto ja asetukset 2021

These reforms are presented in the Vertex CAD major version 27.0.00 (vx. 2021)


We did a thorough overhaul of the rendering (color shading) of the models for version 27.0 (Vertex 2021).

  • The main goal of the reform was to enable larger models to be processed faster on screen.
  • Instead of OpenGL, we use rendering based on Direct 3D technology.
  • This has caused some changes in both the graphics on the screen and the graphics settings. We present these changes centrally here, although there may be excepts from them on other thematic pages as well.

Settings

The meaning and effect of graphics settings

You can adjust some settings related to graphic drawing to your liking.

  • The settings are workstation specific, i.e. with server solutions on the local network, each user can have his own settings on his computer.
  • Some settings affect the resources required of the computer and the video card, so the setting may be a balance between quality and speed.


Renewed graphics settings

You can change the settings:

  • File> User Preferences> Graphics

Some Graphics settings have been removed as obsolete

Because the new rendering is faster, certain old settings are no longer available.

  • Removed settings are marked as red.




The highlight transparency of the selected part

The selected part is drawn in blue so that parts own outlines are drawn. The part is raised "as if up."

  • You can use the slider to adjust the transparency.

Transparency is 0% in the top image, 50% in the middle and 100% in the bottom image.

  • The default is 0%.


Anti-aliasing

With setting anti aliasing you can adjust the drawing of "frame lines".

  • The "softer" the line, the more gray scale is used to draw the line. At the same time, the computational resource required to draw the line increases.

In the top image, the anti aliasing is 0, in the middle 2, and in the bottom image 4.

  • The default is 4

Shadow strength

You can adjust the strength of the shadow to suit your needs. In some cases, e.g. when modeling a part, strong shading can interfere, while the assembly model gets a more vivid look if shadows are included.

In the top image, the shadow strenght is 0 (= no shadow at all), in the middle 2, and in the bottom image 5.




Curve density

This setting affects the drawing of arcs and curves in sketching and the drawing of control curve geometry in part and assembly models.

  • The more smooth the curves you want to draw, the more computational resources are needed to draw.
  • The setting does not affect the drawing of arcs and curves in the drawings.
  • In 3D models, this setting does not affect the drawing of volume models, which is affected by the Draft Accuracy function in the Settings group on the View tab.

In the top image, the density of the curves is 1, in the middle 5 and in the bottom image 20

Give your sketch your own background color

As of version 27.0.00 (Vertex 2021), you can give the sketch the background color you want when it previously got its color from the lower edge color of the model.



Adjust the color of the wireframe model

You can adjust the color of the wireframe model yourself. In the past, color came programmatically on a light and dark background separately.





You can use the environmental image as a background for the model

  • The environmental image appears as a background in both the model and the sketch.

You can change the environmental image from the Environmental Image function in the Environment group of the Rendering ribbon.

Below you see the model on a white background

Below you see the model with the default background


Graphics

The profile to be drawn is drawn shaded

Now the profile starting from the surface or point is drawn shaded. This helps to outline the placement of the profile more accurately than before.

  • Previously the profile was drawn as lines.

Passive parts are drawn dimmer than before

When a part is being edited in an assembly, the edges of the other parts are drawn in a dimmer yellow-green color instead of black lines.

  • This feature emphasizes the passivity of the parts more than before.


Turning the projections is performed on a blank background

As a side effect of rendering reform, the projections are turned in the drawing so that no other geometry in the drawing is displayed during the turn. However, the operation is similar than before.

  • Temporary rotation for viewing purposes: Shift + left mouse button .
  • Permanent rotation to a new position: Ctrl + Shift + left mouse button .




You will see the line binding status continuously

The line binding state (degrees of freedom) is drawn all the time, regardless of whether the Only wireframe or the constraints addition is on.

About the color of the sketch lines:

  • Black.  When a line and it's points are fully defined.
  • Dark purple. When the other end of a line or the center of a circle or arc has been defined . 
  • Light purple.  When a line position is not fixed, even though the line has some constraints like the length, angle, tangent, etc. 
  • Red. When a line is overdefined.
  • Blue. When a line is copied from another part or earlier phase of a part.
  • Grey. When a line does not belong in this sketch.

If for some reason you have given a line a color in its properties, then that color only appears when you are editing a line property and you click the Apply button in the dialog.


The color given to the sketch lines does not appear in the sketch

The color of the sketch lines has been used to model the components for building design (Vertex BD). In mechanical design (Vertex G4), these sketch line colors have no functional significance.

  • The color of a line only appears if you select Properties of the line.
  • If you change the color of the line, press the Apply button in the dialog to update the color you entered on the graphics screen.

Collision detections have been raised to a prominent position

Both static and dynamic collision analysis have been raised to the ribbon of assembly.

  • The ribbon makes these functions faster to use.
  • The collision detection function has had to be redesigned due to, among other things, the rendering reform, so the visualization of collisions now only takes place in the main window instead of the previous three windows.

  • In the large model, you can see the colliding parts better by selecting the Only collisionable parts visible option.






Part rendering feature Wireframe is no longer available

In Rendering > Change Transparency, it is no longer possible to order a part to be drawn with iron wires only.

  • You can still view part of it in wireframe mode in the part own model .








Potential problem with sketching > Previous geometry are not visible.

Problem: In sketching, the lines of part of the previous geometry do not appear.

The problem occurs when:

  • The part is given a LW material in which, in the General setting, the Color is the same as the base color of the sketch, i.e. generally (255,255,255) white and
  • File > User Settings > Graphics > The color of the wireframe is Default and
  • In the sketch, the setting Only wireframe is valid and
  • The background color of the sketch is White.

Solution:

  • Change the Line color of the Wireframe to something other than Default or White (In version 26.0.XX, the color of wireframe was programmatically 72,145,170 = light blue-gray) or
  • Do not use the selection Only wireframe or
  • Change the background color of the draft to other than White.

Note: Even if you don't use the Only wireframe drawing in your sketch, you can see and grab the wireframe shading next to it, if you have turned on the Transparency feature in the Tools group of the Part ribbon before moving to the sketch.

In this example, LW material imitating birch wood has been added to the section. No transparency selected. In the graphics settings, the line color is Default.

  • In the Only Wireframe, the white edges of the part overlap the white background of the sketch.

In this example, the same model is used, but Transparency is selected. Note that in the sketch (center and right) you can see and grab the geometry behind the sketch surface, regardless of whether the Only Wireframe is selected or not.